Настройка Cisco 1700 с картой Ethernet WIC как клиент PPPoE с NAT

Данный документ показывает как настроить Cisco 1700 используя Интерфейсную карту Ethernet WAN (WIC-1ENET) для работы в качестве клиента PPPoE с сетевой трансляцией адресов NAT. Для того, чтобы работать с PPPoE у вас должен быть установлен IOS с поддержкой ADSL PLUS функциональностью. Функциональность ADSL-only не поддерживает PPPoE на Cisco 1700. Несколько компьютеров могут быть установлены за Cisco 1700 маршрутизатором и их трафик посылается по PPPoE сессии, он может быть зашифрован, отфильтрован, и над ним может быть выполнен NAT.

Карта WIC-1ENET обладает следующими ограничениями:
  • WIC-1ENET не поддерживается на платформах отличных от Cisco 1700
  • Поддерживается только витая пара RJ45
  • Нет автосогласования между полудуплексым и полнодуплексными режимами передачи
  • WIC-1ENET не может использоваться для загрузки файлов по TFTP когда роутер находится в режиме ROMMON
  • WIC-1ENET не опознается роутером в режиме ROMMON
  • Текущие Cisco IOS поддерживают WIC-1ENET только в слоте 0 маршрутизатора Cisco 1700
Сетевая диаграмма показана на рисунке:



Здесь на маршрутизаторе Cisco 1700 настраивается клиент PPPoE с помощью команд VPDN. В качестве примера ISP выбран универсальный концентратор доступа Cisco 6400.

Конфигурация Cisco 1700

vpdn enable 
no vpdn logging
!
vpdn-group pppoe
request-dialin  

!--- PPPoE клиент запрашиват установление соединение с устройством агрегации(6400 NRP)

  protocol pppoe
!
int Dialer1
ip address negotiated
encapsulation ppp
ip mtu 1492

!--- Ethernet MTU = 1500 по умолчанию
!--- Выставляем 1492 + PPPoE заголовок = 1500

ip nat outside
dialer pool 1

!--- Завязываем на  Ethernet0.

dialer-group 1
ppp authentication chap callin
ppp chap hostname <username>
ppp chap password <password>
!

!--- The ISP  говорит вам тип используемой аутентификации
ppp pap sent-username <username> password <password>

!
dialer-list 1 protocol ip permit
!

!--- Это внутренняя Ethernet сеть.
interface FastEthernet0
ip address 10.0.0.1 255.255.255.0
ip nat inside
!
interface Ethernet0
pppoe enable
pppoe-client dial-pool-number 1


!--- Код PPPoE клиента завязан на dialer интерфейс с которого клонируется интерфейс virtual-access.  
!

!--- Для NAT указываем интерфейс Dialer1 и добоавляем маршрут по умолчанию
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
dialer-list 1 protocol ip permit

!--- Для целей NAT.
access-list 1 permit 10.0.0.0 0.0.0.255
Конфигурация Cisco 6400 на стороне сервис провайдера (ISP), аналогична приведенной в документе Настройка Cisco Router 827 в качестве PPPoE клиента с NAT
Читайте также:
  • Настройка локальной сети и подключение 2 и более компьютеров к сети Интернет
    Разделим последовательность действий условно на два этапа.Для начала разберем и отбросим вариант, когда вам нужно только разделить Интернет.Подключение к Интернету 2-х компьютеров и более в одной квартире без создания локальной сетиРешить этот вопрос можно несколькими способами:Установка роутера (ма...
  • Настройка Cisco Router 827 в качестве PPPoE-клиента с NAT
    Поддержка PPP поверх Ethernet была введена в Cisco IOS версии 12.1(3)XG. Прежде чем трафик посылается по PPPoE сессии, он может быть зашифрован, отфильтрован, и т.д, а также на ним можно выполнить NAT преобразование.Сетевая диаграмма показана на рисунке:Конфигурация Cisco 827 Router! vpdn enable no ...
  • Безопасность сети: то, что должен знать каждый
    Формируя политику обеспечения безопасности, администратор прежде всего проводит инвентаризацию ресурсов, защита которых планируется; идентифицирует пользователей, которым требуется доступ к каждому из этих ресурсов, и выясняет наиболее вероятные источники опасности для каждого из этих ресурсов. Имея...
  • Локальные проводные сети
    Локальные сети: общие понятияПод локальной сетью (ЛВС, LAN) обычно подразумевают объединение компьютеров, расположенных в ограниченном пространстве. Локальные сети можно объединять в более крупные сети, такие как CAN (группа зданий), MAN (город), WAN (широкомасштабная сеть), GAN (глобальная сеть). П...
  • Локальная сеть из двух компьютеров
    Непосредственное кабельное соединение Если вы не желаете приобретать сетевые карты (которые, между прочим, в последнее время часто встраивают непосредственно в материнские платы) или вас пугают слова типа NETBEUI, IPX/SPX, TCP/IP или DNS, то совершенно бесплатный вариант, встроенный в Windows 95/98...