Настройка Cisco Router 827 в качестве PPPoE-клиента с NAT

Данный документ покажет как настроить клиент PPPoE на ATM интерфейсе (DSL интерфейс) Cisco 827. Данная конфигурация также применима для маршрутизатора Cisco 1700 с ассимитричной абонентской цифровой линией (ADSL). Поддержка PPP поверх Ethernet была введена в Cisco IOS версии 12.1(3)XG. Прежде чем трафик посылается по PPPoE сессии, он может быть зашифрован, отфильтрован, и т.д, а также на ним можно выполнить NAT преобразование.

Сетевая диаграмма показана на рисунке:


Конфигурация Cisco 827 Router

! 
vpdn enable
no vpdn logging

!--- Это все по умолчанию.

!
vpdn-group pppoe
request-dialin    

!--- PPPoE клиент запрашиват установление соединение с устройством агрегации(6400 NRP).

  protocol pppoe
!


!--- Это внутренняя Ethernet сеть.
!
interface Ethernet0
ip address 10.92.1.182 255.255.255.0
ip nat inside
  
!--- Это DSL интерфейс.

!
interface ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in

!--- Все по умолчанию.


!--- PPPoE работает поверх AAL5SNAP. Однако, команда  encap aal5snap не используется.
!
interface ATM0.1 point-to-point
pvc 1/1
  pppoe-client dial-pool-number 1
  

!--- Код PPPoE клиента завязан на dialer интерфейс с которого клонируется интерфейс virtual-access.  

!
interface Dialer1
ip address negotiated
ip mtu 1492

!--- Ethernet MTU = 1500 по умолчанию
!--- Выставляем 1492 + PPPoE заголовок = 1500

ip nat outside
encapsulation ppp

!--- Завязываем на  ATM интерфейс.
  dialer pool 1

!--- The ISP  говорит вам тип используемой аутентификации
  
ppp authentication chap callin
ppp chap hostname <username>
ppp chap password <password>
!

!--- Для NAT указываем интерфейс Dialer1 и добоавляем маршрут по умолчанию

ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
!
!--- Для целей NAT.
access-list 1 permit 10.92.1.0 0.0.0.255
!
Нижеследующая конфигурация расположена на стороне сервис провайдера (ISP).

Конфигурация Cisco 6400 NRP

!--- Локальный  ppp пользователь 
username <username> password <password>


!--- Начинаем с команд  VPDN .
!--- Заметим, что здесь PPPoE привязывается к интерфейсу virtual-template взамен  ATM.
!--- В настоящее время невозможно использовать более одной VPDN группы для PPPoE
vpdn enable
no vpdn logging
!
vpdn-group pppoe
accept-dialin

!--- Режим PPPoE сервера.

  protocol pppoe
  virtual-template 1
!
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
hold-queue 500 in

!--- Привязваем интерфейс virtual-template в VPDN группу
!
interface ATM0/0/0.182 point-to-point
pvc 1/82
  encapsulation aal5snap
  
!--- Необходимая команда на стороне сервера
  protocol pppoe
!

!--- Virtual-template используется вместо интерфейса dialer.
!
interface Virtual-Template1
ip unnumbered Loopback10
ip mtu 1492
peer default ip address pool ippool
ppp authentication chap
!
!
interface Loopback10
ip address 8.8.8.1 255.255.255.0
!
ip local pool ippool 9.9.9.1 9.9.9.5

После того как PPPoE сессия будет установлена, используйте команду show vpdn чтобы посмотреть ее состояние

#show vpdn

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID  RemMAC           LocMAC      Intf  VASt  OIntf   VC
1  0050.7359.35b7  0001.96a4.84ac  Vi1  UP     AT0    1   1
Читайте также:
  • Настройка локальной сети и подключение 2 и более компьютеров к сети Интернет
    Разделим последовательность действий условно на два этапа.Для начала разберем и отбросим вариант, когда вам нужно только разделить Интернет.Подключение к Интернету 2-х компьютеров и более в одной квартире без создания локальной сетиРешить этот вопрос можно несколькими способами:Установка роутера (ма...
  • Настройка Cisco 1700 с картой Ethernet WIC как клиент PPPoE с NAT
    Несколько компьютеров могут быть установлены за Cisco 1700 маршрутизатором и их трафик посылается по PPPoE сессии, он может быть зашифрован, отфильтрован, и над ним может быть выполнен NAT.Карта WIC-1ENET обладает следующими ограничениями:WIC-1ENET не поддерживается на платформах отличных от Cisco ...
  • Безопасность сети: то, что должен знать каждый
    Формируя политику обеспечения безопасности, администратор прежде всего проводит инвентаризацию ресурсов, защита которых планируется; идентифицирует пользователей, которым требуется доступ к каждому из этих ресурсов, и выясняет наиболее вероятные источники опасности для каждого из этих ресурсов. Имея...
  • Локальные проводные сети
    Локальные сети: общие понятияПод локальной сетью (ЛВС, LAN) обычно подразумевают объединение компьютеров, расположенных в ограниченном пространстве. Локальные сети можно объединять в более крупные сети, такие как CAN (группа зданий), MAN (город), WAN (широкомасштабная сеть), GAN (глобальная сеть). П...
  • Локальная сеть из двух компьютеров
    Непосредственное кабельное соединение Если вы не желаете приобретать сетевые карты (которые, между прочим, в последнее время часто встраивают непосредственно в материнские платы) или вас пугают слова типа NETBEUI, IPX/SPX, TCP/IP или DNS, то совершенно бесплатный вариант, встроенный в Windows 95/98...